PV routeur low cost DIY

Informations sur les capteurs et installations.

Modérateurs: Balajol, monteric, ametpierre, ramses

Re: PV routeur low cost DIY

Messagepar wysiwyg » Jeu Nov 23, 2017 11:00 am

Hi,

J'ai pris des photos de mon installation ainsi que des vues de l'oscilloscope, le problème est que je ne sais pas insérer de photos sur le forum...

Le relais statique est branché sur la sortie 10 comme tu le stipules au début de ce post.

J'ai fait une modif au niveau des entrées des signaux, sur la photo où il y la plaque à essai, le ct sensor est injecté en 1 et le signal du transfo en 2 alors que dans le programme, il est déclaré :

byte voltageSensorPin = 1;
byte currentSensorPin = 0;

J'essaie de comprendre un peu le programme mais moi et le C, ça fait deux !

Je visualise le signal de ma pince avec un oscilloscope.

Merci de vos avis éclairés.

Wysiwyg.

wysiwyg
Newbie
Newbie
 
Messages: 14
Enregistré le: Ven Nov 10, 2017 12:46 pm
Localisation: Drefféac, Pontchateau (Entre Nantes et Vannes)
Âge: 55

Re: PV routeur low cost DIY

Messagepar lebritish » Jeu Nov 23, 2017 11:18 am

Bjr,

pour les photos il faut quelles fasse moins de 800 pixels de large je crois bien.
Essayes de les réduire avant de les poster

lebritish
Maitre Solaire
Maitre Solaire
 
Messages: 2175
Enregistré le: Sam Mai 24, 2008 23:18 pm
Localisation: Saint Ambroix (30)
Âge: 43

Re: PV routeur low cost DIY

Messagepar Regismu » Jeu Nov 23, 2017 11:49 am

Bonjour à Tous

pour poster des photos sur un forum : http://forum-photovoltaique.fr/viewtopi ... =49&t=6830
membre actif du GPPEP : http://www.gppep.org/
Association loi 1901, reconnue d'intérêt général

Regismu
Apprenti Solaire
Apprenti Solaire
 
Messages: 316
Enregistré le: Sam Fév 23, 2013 23:32 pm
Localisation: 13

Re: PV routeur low cost DIY

Messagepar wysiwyg » Jeu Nov 23, 2017 12:14 pm

Merci pour le "How to" concernant l'insertion d'images.

Voici quelques photos... J'aurais aimé avoir un snap lorsque il y a excédent de production mais pour l'instant le ciel est gris !

Image

Vous apercevez le câble USB pour le moniteur sur PC mais rien ne s'affiche à l'écran...

En bas à droite le transfo pour le signal secteur injecté sur le bornier bleu en haut puis sur le bornier à gauche la sonde CT. Les fils bleus et rouges à gauche vont sur le relais statique côté puissance.

Image
Le relais statique (la led ne s'allume jamais).

Image
Le signal "sinusoïdal" du transfo.

Image
Ce qui vient de la sonde CT...

Voilà un "bout", je vais essayer de quantifier au plus juste la grandeur de mes signaux...

Wys.

wysiwyg
Newbie
Newbie
 
Messages: 14
Enregistré le: Ven Nov 10, 2017 12:46 pm
Localisation: Drefféac, Pontchateau (Entre Nantes et Vannes)
Âge: 55

Re: PV routeur low cost DIY

Messagepar Hari43 » Jeu Nov 23, 2017 12:52 pm

-Quelle est la référence complète de la pince ampèremétrique ?
-L'oscillo est-il mono ou bi-courbe ?
-Que se passe t'il lorsque la pince CT est inversée ? (ou l'alimentation du transfo si c'est plus accessible mais pas les deux en même temps))
Le moniteur série de l'IDE doit s'incrémenter lorsqu'il y a du surplus (ou lorsque la pince est inversée) jusqu'à un seuil qui provoque le déclenchement du triac ou du SSR.
On peut brancher une led sur la sortie 13 de l'arduino avec une résistance de 220 ohms pour visualiser le déclenchement.

Hari43
Stagiaire Solaire
Stagiaire Solaire
 
Messages: 118
Enregistré le: Dim Jan 31, 2016 18:56 pm
Localisation: 43 Le Puy en Velay

Re: PV routeur low cost DIY

Messagepar domwood » Jeu Nov 23, 2017 13:43 pm

bonjour

peut-être rien à voir, mais j'ai constaté que j'avais deux sortes de relais statiques dans mon stock, avec des tensions d'entrée différentes. 3-32V et 5-30V.
et donc je voyais les 5-30 hors jeu pour l'application.

domwood
Maitre Solaire
Maitre Solaire
 
Messages: 1075
Enregistré le: Ven Avr 02, 2010 17:47 pm
Localisation: langonnet (56)

Re: PV routeur low cost DIY

Messagepar wysiwyg » Jeu Nov 23, 2017 17:05 pm

Merci pour l'intervention.

La sonde est la même que celle décrite plus haut une SCT013 30A/1v.

L'oscillo a 2 canaux.

Il ne se passe rien quand j'inverse phase neutre du transfo.

Image

La "sinusoïde" est le Transfo, l'autre courbe la CT 160mv c à c avec une importation EDF de 124wh

Image

Ici je force mon chauffe eau pour importer de l'électricité, histoire de voir si ma CT réagit.
J'ai 1.25v en c à c sur la patte A0 de l'arduino, import EDF de 3.1 kwh

Je ne sais pas si c'est cohérent !

wysiwyg
Newbie
Newbie
 
Messages: 14
Enregistré le: Ven Nov 10, 2017 12:46 pm
Localisation: Drefféac, Pontchateau (Entre Nantes et Vannes)
Âge: 55

Re: PV routeur low cost DIY

Messagepar Hari43 » Jeu Nov 23, 2017 18:38 pm

Je suis étonné par la première courbe.
Tension et courant semblent en opposition de phase, ce qui caractérise l'injection.
Par contre, en inversant soit la sonde soit l'alimentation du transfo la "sinusoïde" devrait s'inverser.
Quelle tension sur la sortie D10 ?
Sur mon montage avec un moc3021 et un triac le déclenchement est provoqué par le passage à 0V de la sortie trigger D10.
Le soft étant quasiment le même , cela doit se passer de la même manière. Oups le soft en première page est différent actif =+5V donc la led à 0V
Dans un premier temps il faudrait mettre une led en D10 ou D13 avec une résistance 220 ou 330 Ohms et raccordée sur un +5V ( avec la remarque ci-dessus 0v)et qu'elle s'allume...
Le moniteur série de l'IDE indique quoi?
la résistance de 33 Ohms a bien été supprimée?

Hari43
Stagiaire Solaire
Stagiaire Solaire
 
Messages: 118
Enregistré le: Dim Jan 31, 2016 18:56 pm
Localisation: 43 Le Puy en Velay

Re: PV routeur low cost DIY

Messagepar tignous84 » Jeu Nov 23, 2017 20:32 pm

Bon ,les gars,vous m'obligez à accélérer (je viens juste de finir le cablage) j'ai mis sous tension sans micro mais avec LM 358.

Voilà ,en haut la tension qui sort du transfo divisée par 10 environ.
En bas ,4 spires passées dans un CT 100 A 50mA sur une boucle de courant de 3 Amp mesurés .
( secondaire de transfo 220/8 v ;400 VA via un
autotransfo variable (Variac pour les anciens).
Soit 12 Amp efficace

Image

Les phases sont quelconques ;tension d'alim de la carte Robin Vcc =3.3 volts

Toutes choses égales par ailleurs ;ici le CT marqué 30 A /1 V reçu aujourd'hui même :-)

Image

A mon humble avis,vous n'obtiendrez rien de bien propre sans ce genre de formes :-o attention,tous les transfos ne se valent pas
Surtout les petites puissances !!!!

tignous84
Etudiant Solaire
Etudiant Solaire
 
Messages: 229
Enregistré le: Dim Oct 01, 2017 19:04 pm
Localisation: Pernes les Fontaines Vaucluse
Âge: 75

Re: PV routeur low cost DIY

Messagepar Hari43 » Jeu Nov 23, 2017 21:22 pm

Bonsoir tignous84,
Serait-il possible d'avoir les mêmes courbes lorsqu'il y a injection (je ne sais pas si à cette heure il y a encore du surplus dans le midi...)
Tout cela pour voir le déphasage entre U et I


Quelques courbes selon les adaptateurs
https://learn.openenergymonitor.org/electricity-monitoring/voltage-sensing/different-acac-power-adapters

Hari43
Stagiaire Solaire
Stagiaire Solaire
 
Messages: 118
Enregistré le: Dim Jan 31, 2016 18:56 pm
Localisation: 43 Le Puy en Velay

Re: PV routeur low cost DIY

Messagepar tignous84 » Jeu Nov 23, 2017 21:31 pm

PAS SI VITE ,je voulais voir justement la forme d'onde en sortie de transfo Robin
Au vu des différentes courbes ,il a du faire son choix ....

Pour le courant ,je fais des mesures sur table ,j'envoie du courant dans une boucle et je regarde comment réagissent les deux types de pince .

Ensuite,je vais simuler le PV en surplus en utilisant le Triac ....là, ça demande quelques réflexions .
Mais tu les auras tes courbes :grin:

La méthode des petits pas est toujours la meilleure :-D

tignous84
Etudiant Solaire
Etudiant Solaire
 
Messages: 229
Enregistré le: Dim Oct 01, 2017 19:04 pm
Localisation: Pernes les Fontaines Vaucluse
Âge: 75

Re: PV routeur low cost DIY

Messagepar lebritish » Jeu Nov 23, 2017 21:37 pm

pour wysiwyg :
pour moi tes signaux sont bons (pas terribles en fait mais ca devrait faire l'affaire)
J'ai l'impression que tu as un prbl logiciel.
As-tu resussi a flasher le logiciel (sketch) ds l'arduino sans probleme ? pas de message d'erreur ?
il se pourrait que le prbl vienne de là car il n'est pas normal que tu n'ai rien dans l'IDE.
Tu ouvres bien le moniteur série ds l'IDE ? (ctrl+shift+M) pr visualiser ? le baud rate est bien a 9600 ?

lebritish
Maitre Solaire
Maitre Solaire
 
Messages: 2175
Enregistré le: Sam Mai 24, 2008 23:18 pm
Localisation: Saint Ambroix (30)
Âge: 43

Re: PV routeur low cost DIY

Messagepar wysiwyg » Jeu Nov 23, 2017 22:52 pm

J'attends demain avec impatience pour pouvoir injecter... niark, niark...

J'ai bien flashé le logiciel dans l'arduino et de mémoire sans erreur. Mais je vais lui en remettre une petite dose !

Le moniteur série je l'ouvre comme c'est prévu, j'ai déjà fait quelques autres essais de programmation (j'apprends) avec l'arduino et cela fonctionnait en 9600 bien sûr.

Bonne soirée, nuit.

Wys.

wysiwyg
Newbie
Newbie
 
Messages: 14
Enregistré le: Ven Nov 10, 2017 12:46 pm
Localisation: Drefféac, Pontchateau (Entre Nantes et Vannes)
Âge: 55

Re: PV routeur low cost DIY

Messagepar wysiwyg » Ven Nov 24, 2017 15:18 pm

Hello,

@Hari43, mon oscilloscope était mal réglé et effectivement en exportation de courant, je suis en opposition de phase (même avec mon signal crade) et quand j'enclenche un gros consommateur, les deux signaux sont en phase.
Sur la sortie 10 j'ai que dalle ou un signal de sinusoïde de daube...

Pour l'instant pas de possibilité de faire du surplus, pour la suite des tests, du fait du temps de m.... :roll:

A plus.

Wys.

PS : @lebritish, j'ai flashé le programme à nouveau, j'attends le soleil...

wysiwyg
Newbie
Newbie
 
Messages: 14
Enregistré le: Ven Nov 10, 2017 12:46 pm
Localisation: Drefféac, Pontchateau (Entre Nantes et Vannes)
Âge: 55

Re: PV routeur low cost DIY

Messagepar lebritish » Ven Nov 24, 2017 16:27 pm

wysiwyg a écrit:Sur la sortie 10 j'ai que dalle ou un signal de sinusoïde de daube...
PS : @lebritish, j'ai flashé le programme à nouveau, j'attends le soleil...


Maintenant que je relis le code je pense qu'il faut cabler le relais sur la sortie 9 et non pas sur la 10 !!!
Sorry pour la boulette !!

lebritish
Maitre Solaire
Maitre Solaire
 
Messages: 2175
Enregistré le: Sam Mai 24, 2008 23:18 pm
Localisation: Saint Ambroix (30)
Âge: 43

PrécédenteSuivante

Retourner vers Photovoltaïque

Qui est en ligne

Utilisateurs parcourant ce forum : fred04 et 1 invité