EM4 problème envoi mail iintempestif data Logging

Modérateurs: Balajol, monteric, ramses

EM4 problème envoi mail iintempestif data Logging

Messagepar jp95520 » Mar Nov 07, 2017 16:10 pm

Bonjour,

j'utilise un EM4 ethernet pour gérer des dépassement de températures avec des blocs fonction Data Logging pour envoyer des mail en cas de dépassement de température, mon problème est que j'ai des envois de mails alors qu'il n'y a pas de problème de dépassements (j'enregistre par ailleurs les températures avec aussi la fonction Data Logging sur un site FTP donc je sais qu'il n'y a pas de dépassements).

Sur les blocs data logging J'ai essayé avec "Archiver périodiquement" ou sans, avec l'entrée Validation déconnectée ou validée lors d'un dépassement de température... quoi que je fasse et bien sans dépassement de température j'ai quand même 1 envoi de mail par jour, pas toujours à la même heure....

Quelqu'un aurait une idée pour éviter ce problème... parce que jouer à Pierre et le loup fini par créer du laxisme chez les utilisateurs...

Merci

JP

jp95520
Newbie
Newbie
 
Messages: 1
Enregistré le: Mar Fév 04, 2014 11:30 am
Localisation: 95520

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar Christian D » Mer Nov 08, 2017 23:08 pm

Bonjour,

l'entrée validation ou la case "archiver périodiquement" gérent l'archivage et pour l'envoi il faut regarder dans "communication" si l'envoi périodique est activé.
C'est peut-être aussi un bug, une nouvelle version est disponible (voir le site de kikologic.fr)
Il y a eu des modifs sur le datalog.
Cdrl
Christian

Christian D
Newbie
Newbie
 
Messages: 31
Enregistré le: Jeu Déc 25, 2014 22:38 pm
Localisation: Nantes

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar syrinx » Mar Fév 06, 2018 8:34 am

Bonjour à tous,

Il y a beaucoup de bugs dans l' em4 de Crouzet. J'attends depuis 6 mois que le SAV fasse quelques choses mais ils sont peu concernés (ou débordés ou lents) malgré mes 3 em4 et 1 M3 (qui est fiable lui).

. La fonction Datalog plante après le 2e envoi d'emails. On a vu que le bloc message emails Event ne plante pas car je continue à les recevoir même quand le Datalog est planté. La solution est de relancer l'em4. Sur certains forums, j'ai lu que certains branchent l'em4 sur un programmateur horaire pour ça...

La suite des bugs:
. Je suis en limite de mémoire, j'ai parfois un changement de date intempestif, retour en 2014. Certainement dû à un gros plantage. Est-ce que l'OS de l'em4 ne serait pas buggé aussi ?
. L'interface de programmation em4Soft sous Windows 10 fonctionne mal: plantage, fonction undo/redo qui prend 1 minute pour chaque undo, mode debugging très lent (idem 1 minute d'attente pour quitter une boîte de dialogue de paramétrage, l'automate PLC est plus lent aussi), possibilité d'entrer en mode debugging qu'après le transfert du programme (sinon il considère toujours que les versions sont différentes), fenêtre écran de l'automate PLC décalée quand on la déplace, les fenêtres de paramétrage des blocs ne se mettent pas toujours à jour (elles affichent souvent la valeur de la fenêtre consultée précédemment et donc on écrase les bonnes valeurs si on n'est pas vigilant).


. Ergonomie de l'em4 Soft: difficile de déplacer les fils, pertes des noms des fils quand on les déplace, impossible de changer l'ordre des entrées et sorties des macros, les fils font souvent des nœuds, impossible de déplacer un ensemble de blocs à l'écran sur quelques cm (car le logiciel croit qu'on le superpose avec ce même ensemble), se déplacer dans la fenêtre de programmation est très lent lorsqu'on déplace un objet, obligation de créer des macros car on arrive vite au maximum de blocs utilisables par écran, parfois des macros identiques sont gérées comme une seule (une modification dans l'une est faite dans toutes les autres) parfois il faut modifier les macros une par une (toujours les mêmes), enregistrement du programme sous Windows parfois impossible (vers un répertoire local Google Drive), transfert du programme vers l'automate lent, et divers points d'ergonomie secondaire.

. Il faut aussi savoir que le nombre de blocs texte affichables par écran est limité (on y arrive très vite), on est assez rapidement limité par la mémoire disponible (et visiblement l'automate plante quand on s'approche du max).

Je suis donc consterné et gêné dans mon travail de voir ça alors que ce serait un excellent produit si Crouzet ne se reposait pas sur ses lauriers. Le Millenium 3 M3 est excellent. Le Crouzet em4 est sorti en 2015 ou 2016, et les bugs sont encore nombreux et le support est très lent, il faut même réagir vivement pour obtenir une réponse (à ne pas confondre avec une solution !)

Merci à votre forum et ses didacticiels qui m'ont souvent inspiré depuis 9 ans que je bricole sur mes automates Crouzet.

syrinx
Newbie
Newbie
 
Messages: 12
Enregistré le: Dim Aoû 09, 2009 20:29 pm
Localisation: Roumanie

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar syrinx » Mer Fév 07, 2018 7:28 am

Il y a là quelques solutions mais bien peu: http://dbhsarl.eu/forum/viewtopic.php?f ... 274#p26278

syrinx
Newbie
Newbie
 
Messages: 12
Enregistré le: Dim Aoû 09, 2009 20:29 pm
Localisation: Roumanie

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar PIWAI » Jeu Fév 08, 2018 11:00 am

Bonjour,
Déjà utilisateur de M3 et de M4 (en version local ethernet). Je me suis rapproché de Crouzet pour avoir des informations sur l'EM4 version remote.

Voici la réponse que je viens de recevoir de la part de leur support :

Bonjour,

Suite à votre demande, veuillez trouver ci-dessous des éléments de réponse.

Le produit em4 Remote est, à ce jour, en arrêt de commercialisation, les produits disponibles sont : Local, Ethernet et Alert 3G

Voir le lien ci dessous pour les produits em4
http://automation.crouzet.fr/produits/em4-nano-plc/
...


Je comprend qu'ils ont du mal à voir la fin de leurs résolutions de problèmes pour en arriver à interrompre une commercialisation !

Bonne journée à tous,
Py,

PIWAI
Newbie
Newbie
 
Messages: 45
Enregistré le: Mer Avr 07, 2010 22:29 pm
Localisation: Finistère (29)

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar syrinx » Dim Fév 11, 2018 23:31 pm

Ils abandonneraient donc leur plateforme web. De mémoire, c'était un abonnement mensuel, assez cher pour nous. Quel échec...

syrinx
Newbie
Newbie
 
Messages: 12
Enregistré le: Dim Aoû 09, 2009 20:29 pm
Localisation: Roumanie

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar yan_alp73 » Dim Avr 15, 2018 15:58 pm

Bonjour,
Je viens d'acheter un EM4 ethernet et j'essaye depuis 2 jours d'envoyer des emails sur événements : impossible erreur 3163:Impossible de se connecter au serveur SMTP.
Est ce que quelqu'un a déjà utilisé cette fonction?
merci
yan_alp73

yan_alp73
Newbie
Newbie
 
Messages: 3
Enregistré le: Ven Nov 12, 2010 10:23 am
Localisation: bourg saint maurice

Re: EM4 problème envoi mail iintempestif data Logging

Messagepar Christian D » Lun Mai 21, 2018 22:15 pm

Bonjour,
En général c'est l'URL qui n'est pas bon.
Cdrl
Christian

Christian D
Newbie
Newbie
 
Messages: 31
Enregistré le: Jeu Déc 25, 2014 22:38 pm
Localisation: Nantes


Retourner vers Crouzet M2-M3, autres API et péripheriques

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités