interface 868mhz panSTamp pour Crouzet Millenium 3 wireless

Modérateurs : monteric, ramses, Balajol

Avatar du membre
panMillenium
Stagiaire Solaire
Stagiaire Solaire
Messages : 67
Enregistré le : mar. mars 12, 2013 8:54 am
Localisation : France isere (38)

Message par panMillenium »

ouhhh super, mais faut il inventer un nouveau registre "PID" pour rester elligible dans le sous forum regulation ? cheers

Avatar du membre
panMillenium
Stagiaire Solaire
Stagiaire Solaire
Messages : 67
Enregistré le : mar. mars 12, 2013 8:54 am
Localisation : France isere (38)

Message par panMillenium »

Bonjour a tous !

notre ami Daniel est en train de sortir un produit par jour avant son expo a san francisco !

la bonne nouvelle du jour (surtout pour ceux qui on des diris) c'est ce nouveau petit module avec une interface RS485 (et peut etre rs232) qui va permettre de s'attaquer au modbus:

http://www.panstamp.com/announcements/m ... monitoring

encore de bonnes choses en perspectives...

Normand
Newbie
Newbie
Messages : 17
Enregistré le : mer. juin 09, 2010 11:20 am
Localisation : Manche 50

Message par Normand »

Bonjour
Super nouvelle,je le commande dés sa mise à disposition!
La COM avec les 3Xd26 toujours Ok!
J'ai bien reçu ma commande de Daniel:
Pour les antennes,pas de problème de mise en place sur le PanStick et module TempHum,sur les panMillenium,il faudra inverser le connecteur du haut,le support antenne ne passe pas.
D'autre part,j'ai encore du rater une marche ,après avoir programmé mon TeBattery-board-DHT22 avec " sample temphumpress application" du site panStamp je ne vois aucune trame sur Realterm.A la mise sous tension Status clignote 2s mais rien ne ce passe! J'ai tenté de modifier TX_INTERVAL register avec valeur A (pour 10s,je pense),pas de changement.Un teste avec un eepromToFacrtoryDefaults() idem..
Pour l'installation de Python SWAPdmt,jai eu la bonne fenêtre au premier lancement,pour le deuxième,fenêtre SWAPdmt vide et trames dans fenêtre de commande Window..
En attente de jours meilleurs ,bonne journée!

raynald60
Newbie
Newbie
Messages : 16
Enregistré le : lun. févr. 16, 2009 11:16 am
Localisation : sarcus 60

Message par raynald60 »

salut
peux tu mettre une photo de l antenne soudee sur la carte
ainsi que le lien
merci raynald

Avatar du membre
panMillenium
Stagiaire Solaire
Stagiaire Solaire
Messages : 67
Enregistré le : mar. mars 12, 2013 8:54 am
Localisation : France isere (38)

Message par panMillenium »

Bonsoir,

en effet, le connecteur 16 point sur la face du panMillenium c'est pas la meilleure idée que j'ai eu . on peu couper la premiere rangée de patte avec une pince coupante (...) dans ce cas la programation doit se faire avec la rangée restante et uniquement avec un panStick (pas le ftdi). ...

pour le dht22, cest bizarre,
tu mets le panstamp sur ton panstick,
tu lance arduino
tu charges les sketch "temphum.ino"
et tu envoie la purée....
tu remet le panstamp sur le temphum et tu mets une pile1V5

à partir de la, le temphum envoie dès la mise sous tension 2 trames : product & status-sync, en utilisant le numero de noeud par defaut 255.
puis il se met à cligonter 6 fois 500ms=3s
(cest pendant ce laps de temps qu'il peux accepter une commande de changement d'adresse ou de txinterval)
et juste apres il envoie les premieres valures temp-hum, puis la tension de la baterie, et une trame pour dire qu'il est repassé en RXON.
de la il se reveille ensuite en fonction du txinterval, qui est parametré par défaut à 0xFFFF ce qui doit faire 11heures...

tiens nous au courant, je vais reflechir de mon coté

moriss
Etudiant Solaire
Etudiant Solaire
Messages : 291
Enregistré le : mar. juil. 13, 2010 17:48 pm
Localisation : lyon

Message par moriss »

Pour les noobs comme moi, on pourrait avoir 2/3 photos et un peu de concret pour mieux comprendre ce bel outil ?

Normand
Newbie
Newbie
Messages : 17
Enregistré le : mer. juin 09, 2010 11:20 am
Localisation : Manche 50

Message par Normand »

Bonjour
Merci pour les infos du "TempHumidité"
Effectivement ,à la mise sous tension ,j'ai bien les 6 impulsions sur la LED statuts ,toujours pas de trame sur Realterm,pas de problème pour celles de mes PanMillenium!
J'ai testé le sketch "brut" de Daniel et ce ,en programmant le panStample de mon Panstick,idem,idem..
Deux photos d'antennes soudées sur panstamp,pour faire le teste sur panMillenium,en inversant le connecteur,il me faut recommander des supports (vue les photos du ,store je pensais qu'ils étaient par lot de deux!)
A suivre
Fichiers joints
Carte_Temp_Humidité_Antenne.pdf
(123.42 Kio) Téléchargé 205 fois
PanStamp +Antenne.pdf
(56.83 Kio) Téléchargé 204 fois

Avatar du membre
panMillenium
Stagiaire Solaire
Stagiaire Solaire
Messages : 67
Enregistré le : mar. mars 12, 2013 8:54 am
Localisation : France isere (38)

Message par panMillenium »

a tu essayer d'echanger les panstamps, entre celui du panstick et celui du temphum? pour verifier s'il y en a un en panne...? ou si cest purement software

Normand
Newbie
Newbie
Messages : 17
Enregistré le : mer. juin 09, 2010 11:20 am
Localisation : Manche 50

Message par Normand »

J’ai bien pensé à faire ce teste de reprogrammation ,en inversant les panStamp ,pas de trame avec temphumidité et le panStamp rechargé avec ModemExtend,fonctionne,va comprendre ! J’utilise arduino 1.0.4 et windows 7 32b,j’ai testé sur un autre pc sous windows 7 64b ,sans changement. Problème logiciel..mise en service..la reprogrammation du panStamp sur panStick avec ModemExtend,fonctionne ,alors la démarche est bonne ..et j’utilise du :

panstamp_sketches.zip
panStamp firmware . Arduino sketches 199k v. 27 May 1, 2013, 3:01 AM Daniel Berenguer

L’exemple « temphumpress » ; c’est le bon sketche je pense..
A suivre,bonne soirée.

Avatar du membre
panMillenium
Stagiaire Solaire
Stagiaire Solaire
Messages : 67
Enregistré le : mar. mars 12, 2013 8:54 am
Localisation : France isere (38)

Message par panMillenium »

ok ok. si ca peux te consoler, j'ai l'impresion d'avoir a peu pres le meme probleme juste là ce soir :shock:
j'ai un panstamp qui servait pour l'application modem sur un panstick. Je lui ai rajouter une antenne avec un connecteur. Ca marchait tres bien.
j'essaye ce soir : nada, recoit rien. par contre, j'ai pu verifier que la communication entre le 328p et le cc1101 fonctionne.
Je me demande si l'entrée antenne (LNA=low noise amplifier) ne serait pas un peu sensible à l'ESD et s'il n'est pas cramé... à suivre...
[edit] euh dailleur il ne transmet plus non plus...
Modifié en dernier par panMillenium le mer. mai 15, 2013 20:37 pm, modifié 1 fois.

Normand
Newbie
Newbie
Messages : 17
Enregistré le : mer. juin 09, 2010 11:20 am
Localisation : Manche 50

Message par Normand »

Bon je pense avoir trouvé :
J’ai utilisé des antennes d’un routeurs D_Link que je pensais compatible mais problème, le connecteur SMP est femelle et celui pour panStamp vendu par Daniel aussi femelle et,en connectique, femelle /femelle ça ne passe !
10 cm de câble de maintenant de la COM !!!
Bon un pas de plus,comment je peux me faire avoir..peut-être as tu le même
problème.
Bonne soirée

raynald60
Newbie
Newbie
Messages : 16
Enregistré le : lun. févr. 16, 2009 11:16 am
Localisation : sarcus 60

Message par raynald60 »

salut
j aurai besoin de quelques fichiers capture avec la date et heure
fait avec realterm
contenant differents exemples pour faire un petite inteface de supervision exploitable



raynald

raynald60
Newbie
Newbie
Messages : 16
Enregistré le : lun. févr. 16, 2009 11:16 am
Localisation : sarcus 60

Message par raynald60 »

salut a tous
un peti prog en cour de developpement pour la capture comme realterm

https://dl.dropboxusercontent.com/u/218 ... niTerm.rar

Avatar du membre
panMillenium
Stagiaire Solaire
Stagiaire Solaire
Messages : 67
Enregistré le : mar. mars 12, 2013 8:54 am
Localisation : France isere (38)

Message par panMillenium »

Bonjour à tous les pan-afficionados / Hola !

après la contribution de reynald, ce topic se ralenti. ça coïncide à peu près avec l'apparition des grosses chaleurs donc j'imagine que les panneaux tournent à fond.

de mon coté j'ai pas mal bossé sur la refonte de certaines librairies de base de l'application panMillenium, avec l'objectif de gagner un bon kilo octet de mémoire RAM, pour pouvoir implémenter une solution de communication des trames Modbus en passthroug à travers le protocole swap, pour permettre l'utilisation du monitoring Crouzet Logic et de smart app;
soyons franc, il y a encore pas mal de boulot et je me suis récemment égaré sur 2 autres petits projets (utilisation et portage sur microprocesseur CC430, et mise en service d'un système DSP pour mon install hifi-audio).

en clair, je pense continuer la direction prise, mais ça va prendre du temps, et le break des vacances ne va pas forcément accélérer tout ça :)

bon sinon de votre coté, y a til des idées nouvelles qui sont venues à vos esprits ? ou quelques bonnes perspectives ? la communauté est plutôt réduite et nous pourrons peut être intéressé d'autres forumeur en parlant d'applications concrètes plutôt que de techno. a voir. (il me reste 4 ou 5 pcb by the way)

bien à vous et n'oubliez pas crème, casquette et chaise longue

Avatar du membre
Samounet
Expert Solaire
Expert Solaire
Messages : 617
Enregistré le : sam. août 02, 2008 18:38 pm
Localisation : Saint Caprais (32)

Message par Samounet »

Bonjour FAbrice,

En fait, je ne te cache pas que j'attends avec impatience la fonction passthrough pour remplacer le câble.

Dans l'utilisation que j'ai aujourd'hui du PanMillenium, ça apparaît vraiment comme un "must".

Je pense que cette potentialité toute bête (ça fait drôle d'écrire ça quand je sais le travail que tu passes dessus) peut-être la première étape pour l'adoption du système.

Bonne vacances tout de même,

A+++

Répondre

Retourner vers « PanMillenium »